Page 1 of 1

Menu doesn't work on mobile version

Posted: Wed Aug 30, 2017 10:20 am
by redfan10
Hello,

I have this issue:

Firs there was a menu in the header and after that in the mobile version of the site, the menu doesn't work. I use Child theme and copied the code the header.php code from mother theme to the header.php of the Child theme. The link of the site is



Greetings

Re: Menu doesn't work on mobile version

Posted: Tue Sep 05, 2017 10:42 pm
by admin
Hi redfan10,
Sorry for the late reply!

The mobile menu is working correctly on my testing website. But the icons are missing and they are replaced by random text like in the screenshot below;
Image
The reason behind this, the font icon set is not loading. As a quick fix, open functions.php and scroll down to line 120 then change this line;
wp_enqueue_style( 'materialicons', '//fonts.googleapis.com/icon?family=Material+Icons', false, null, 'all' );
To this;
wp_enqueue_style( 'materialicons', 'https://fonts.googleapis.com/icon?family=Material+Icons', false, null, 'all' );
In the past the previous code used to work but now it doesn't load all required font files, it only loads the font CSS file. Maybe Google has removed redirects from HTTP to HTTPS for their static resources or something similar because this code was working since the release of Realistic.
Of course you need to do the same to load Roboto font;
wp_enqueue_style( 'roboto_google_font', 'https://fonts.googleapis.com/css?family=Roboto:400italic,300,700,400', false, null, 'all' );
For the off canvas menu it's working on my website;
Image
Click your mouse right button then Inspect (CTR+SHIFT+I) and tell me what kind of JavaScript errors are showing in the console?

Edit: By the way, I have an update for Realistic that I am currently testing but please not that a lot of files were changed and functions removed/renamed so if you are extending Realistic using a child theme, make sure you test the update because you will receive and error or blank page if in your child theme calls a function that is no longer available/defined. This update should come out very soon. Maybe tomorrow at most.

Re: Menu doesn't work on mobile version

Posted: Mon Nov 20, 2017 7:18 pm
by EfrenRet
Great info Asmi, thanks for sharing. Works like a charm.

Re: Menu doesn't work on mobile version

Posted: Mon Nov 27, 2017 5:45 pm
by admin
EfrenRet wrote:Great info Asmi, thanks for sharing. Works like a charm.
Hi EfrenRet,
Thanks for passing by :) Glad I helped you!

Menu doesnt work on mobile version

Posted: Mon May 20, 2019 5:40 pm
by Pascalkit
im on the latest version and downloaded all the tracks except the pure mx links, im just missing decals now, are there any object packs or anything ?