Page 1 of 2

Problem Is Post Timestamp

Posted: Mon Dec 11, 2017 10:15 pm
by TahMiD
When I publish the post, the Timestamp should show "x min ago" or "x second ago". But the theme timestamp always shows "6 hours ago" in the latest published post. how to fix that?

Re: Problem Is Post Timestamp

Posted: Thu Dec 14, 2017 12:21 am
by admin
Hi,
You sure about this? Try to deactivate all your plugins and publish a post and check if the timestamp is correct (you don't need to do this on a production website, you can setup a local website easily using XAMPP or WampServer). On my local WP installation, I get the correct timestamp so please check if a plugin is causing this.

Re: Problem Is Post Timestamp

Posted: Thu Dec 14, 2017 2:32 am
by TahMiD
Thanks For The reply, OK, I will investigate that.

Re: Problem Is Post Timestamp

Posted: Fri Dec 15, 2017 2:49 pm
by TahMiD
Oops!! I was deactivated all plugins after publishing a new post, but the problem was still on there. Its always showing 6 Hours Ago. Plz, Send me another timestamp code and the Tutorial on how can I apply that.

Re: Problem Is Post Timestamp

Posted: Fri Dec 15, 2017 8:04 pm
by admin
That's very weird. Maybe the theme fails to retrieve the post global variable but it is working fine on my local website and also on the demo site http://realistic.themient.com
Try this; open /inc/common.php file, scroll down to line 68 until you find the realistic_posted() function and change this line (line 71):
$time_format = 'ago_format';
To this:
$time_format = 'traditional';
Now the default timestamp will be displayed. The date format will depend on the Date Format option in the Settings => General. You should get a date like this "December 15, 2017".
Let me know if you get the correct date this time.

Re: Problem Is Post Timestamp

Posted: Fri Dec 15, 2017 8:06 pm
by TahMiD
Ok let me try this..

Re: Problem Is Post Timestamp

Posted: Fri Dec 15, 2017 8:16 pm
by TahMiD
Now It Is Showing another Problem
Screenshot_1.jpg
Screenshot_1.jpg (71.56 KiB) Viewed 2385 times

Re: Problem Is Post Timestamp

Posted: Fri Dec 15, 2017 8:17 pm
by TahMiD
Maybe It's showing the publishing date and last modified date.

Re: Problem Is Post Timestamp

Posted: Fri Dec 15, 2017 8:20 pm
by TahMiD
Previous x Time Ago was awesome. but it was "6 hours ago" in the latest published post. but after that I was ok, I mean after 1 hour Its showing 7 hrs ago, 8 hrs ago etc.

Re: Problem Is Post Timestamp

Posted: Sun Dec 17, 2017 8:20 pm
by admin
TahMiD wrote:Maybe It's showing the publishing date and last modified date.
If you make this change, you date must be like in the screenshot;
Image
Am afraid this issue is internal. The ago function will show a weird date (1970!) but only if your post is not yet published.
Give me a link to your website, I will take a look.